5d777f5b8ae19687d8d6d03c88860a35289f45c1
[portage-overlay.git] / dev-libs / libgcrypt / libgcrypt-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: Exp $
4
5 EAPI=5
6
7 inherit autotools flag-o-matic user git-2
8
9 DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
10 HOMEPAGE="http://gnupg.org/"
11
12 WANT_AUTOMAKE=1.14
13 EGIT_REPO_URI="git://git.gnupg.org/${PN}.git"
14
15 LICENSE="GPL-2"
16 SLOT="0/20"
17 KEYWORDS=""
18
19 IUSE=""
20
21 REQUIRED_USE=""
22 #Texinfo version 4.8 segfaults, force higher version.  
23 CDEPEND=">=dev-libs/libgpg-error-1.13"
24 DEPEND="
25         >=sys-apps/texinfo-5.2:0
26         media-gfx/transfig
27         app-text/ghostscript-gpl
28         ${CDEPEND}
29 "
30 RDEPEND="${CDEPEND}"
31
32 src_prepare() {
33         ./autogen.sh || die "Autogen failed"
34 }
35
36 src_configure() {
37         econf \
38                 --enable-maintainer-mode
39 }