b6bfc45b2daa00175bc90495ce2890edb6af65ae
[portage-overlay.git] / net-misc / polly / polly-0.93.11-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/polly/polly-0.93.11.ebuild,v 1.1 2014/02/12 10:50:41 jlec Exp $
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python{2_6,2_7} )
8 DISTUTILS_NO_PARALLEL_BUILD=1
9
10 inherit distutils-r1 gnome2-utils vcs-snapshot
11
12 DESCRIPTION="twitter client designed for multiple columns of multiple accounts"
13 HOMEPAGE="https://launchpad.net/polly"
14 SRC_URI="https://launchpad.net/${PN}/1.0/pre-alpha-2/+download/Polly-${PV}%20%28pre-alpha%203.11%29.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="CC-BY-NC-SA-3.0 GPL-2 GPL-3+ MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
22 RDEPEND="${PYTHON_DEPS}
23         dev-python/dbus-python[${PYTHON_USEDEP}]
24         dev-python/gconf-python
25         dev-python/gtkspell-python
26         dev-python/httplib2[${PYTHON_USEDEP}]
27         dev-python/keyring[${PYTHON_USEDEP}]
28         dev-python/notify-python[${PYTHON_USEDEP}]
29         dev-python/numpy[${PYTHON_USEDEP}]
30         dev-python/oauth2[${PYTHON_USEDEP}]
31         dev-python/pycurl[${PYTHON_USEDEP}]
32         dev-python/pyxdg[${PYTHON_USEDEP}]
33         dev-python/socksipy[${PYTHON_USEDEP}]"
34 DEPEND="${PYTHON_DEPS}"
35
36 python_prepare_all() {
37         rm -rf external/keyring || die
38         distutils-r1_python_prepare_all
39 }
40
41 pkg_preinst() {
42         gnome2_gconf_savelist
43 }
44
45 src_prepare(){
46         epatch "${FILESDIR}/${P}-fix_account_reactivation_need.patch"
47         default
48 }
49
50 pkg_postinst() {
51         gnome2_gconf_install
52 }
53
54 pkg_postrm() {
55         gnome2_gconf_uninstall
56 }