9749569d5ed6b0b33d380b80a63b606c7501f247
[portage-overlay.git] / net-voip / blink / blink-4.1.0_p20141125.ebuild
1 # Copyright 2014-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-crypt/gkeys/gkeys-9999.ebuild,v 1.2 2014/12/25 20:58:50 dolsen Exp $
4
5 EAPI="5"
6
7 PYTHON_COMPAT=(python2_7)
8
9 inherit distutils-r1
10
11 DESCRIPTION="SIP-client"
12 HOMEPAGE="http://ag-projects.com/"
13 SRC_URI="http://download.sumptuouscapital.com/gentoo/${P}.tar.bz2"
14
15 LICENSE="LGPL-2"
16 SLOT="0"
17 IUSE=""
18
19 KEYWORDS="~amd64 ~x86"
20
21 CDEPEND="dev-python/PyQt4[webkit,${PYTHON_USEDEP}]
22          dev-python/lxml[${PYTHON_USEDEP}]
23          dev-python/cython[${PYTHON_USEDEP}]
24          dev-python/python-application[${PYTHON_USEDEP}]
25          dev-python/python-cjson[${PYTHON_USEDEP}]
26          dev-python/twisted-core[${PYTHON_USEDEP}]
27          dev-python/python-sipsimple[${PYTHON_USEDEP}]
28          dev-python/zope-interface[${PYTHON_USEDEP}]
29          dev-python/python-dateutil[${PYTHON_USEDEP}]
30          dev-python/django[${PYTHON_USEDEP}]
31          dev-python/python-msrplib[${PYTHON_USEDEP}]
32          dev-python/redis-py[${PYTHON_USEDEP}]
33          net-libs/libvncserver"
34
35 DEPEND="${CDEPEND}"
36
37 RDEPEND="${CDEPEND}"
38
39 S="${WORKDIR}/blink-qt"
40