(app-crypt/gnupg, dev-libs/libgcrypt): Automake 1.14
authorKristian Fiskerstrand <kf@sumptuouscapital.com>
Sun, 25 Jan 2015 19:52:14 +0000 (20:52 +0100)
committerKristian Fiskerstrand <kf@sumptuouscapital.com>
Sun, 25 Jan 2015 19:52:14 +0000 (20:52 +0100)
Bumping automake requirement and removing patches that
allowed to build with newer automake as this is now
possible using the standard upstream versions

app-crypt/gnupg/Manifest
app-crypt/gnupg/files/gnupg_master_0002-Fix-building-with-GNU-Automake-1.13.patch [deleted file]
dev-libs/libgcrypt/Manifest
dev-libs/libgcrypt/files/0002-Fix-building-with-GNU-Automake-1.13.patch [deleted file]
dev-libs/libgcrypt/libgcrypt-9999.ebuild

index 27b76a6..ef040f1 100644 (file)
@@ -1,3 +1,2 @@
 AUX gnupg-2.0.17-gpgsm-gencert.patch 1121 SHA256 fa8369a4466b3cce54215a348940422f46f4d359f9e9b3c7029a1138870888df SHA512 ecde032b205cc16c33ff21ded55b93e74058cd804d68e4a0738ac70d54b5b388b6f709d21719a5e418c662b7ee74bc4aef7a0c59de106e2d4bd06b7bc1a11138 WHIRLPOOL 5dc4d3de29290e8e274a0f4fef871cea7f49553846254d819ca776000978a72c694212559d9ad03312f94f71f406de4641c0575188d340017a7937b01753b8a0
-AUX gnupg_master_0002-Fix-building-with-GNU-Automake-1.13.patch 2143 SHA256 2413ac5c9607450c7792c52754d4500249ab5e07ded649c752f89f243cf43b4e SHA512 adf90513afd9b3c7384b53e3b5b95c305567b6707ed9a60d76e49b28744e358da4b4412b0df266e9a214e3c4fbcf9ebe8523584436143b7e57aca620a0db422e WHIRLPOOL f2d2f59656caf1abfaf0066383deb1d27aab43c2b25bd3a9fa27cf3c4a0357e875058ef138b7a5237526fece6c3910604deac5fec6af01ada97e88f7b44b54bf
 EBUILD gnupg-9999.ebuild 4811 SHA256 6faf1b6ec2ee7bf8864967d26cfefbf1d4529040e7e0a1311c14b8301d5e7f3e SHA512 9ee8193f3c53c3c5b35418401199cf71c7076994c618506677f275acf453f4778d8a8348c2cc8a0a7c879538544f8e8ed5f14fddef0611c325cbc27046a9f509 WHIRLPOOL f04d375fa6aa293bf650a183d6cc1a6d65e0213209e6fcd81669cab857549ca9b0e6cfa3642158766205e094f040cd33031fb0393e5f4b9743c2955ca2c102ca
diff --git a/app-crypt/gnupg/files/gnupg_master_0002-Fix-building-with-GNU-Automake-1.13.patch b/app-crypt/gnupg/files/gnupg_master_0002-Fix-building-with-GNU-Automake-1.13.patch
deleted file mode 100644 (file)
index 797c64d..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-From c83f37c0b24671b3afd558f37b0da3b22e35ceef Mon Sep 17 00:00:00 2001
-From: Christian Aistleitner <christian@quelltextlich.at>
-Date: Sun, 14 Jul 2013 13:00:19 +0200
-Subject: [PATCH] Fix building with GNU Automake 1.13+
-
-* configure.ac: Force serial tests for GNU Automake 1.13+.
-(serial_tests): New.
---
-
-GNU Automake switched the default test harness to parallel beginning
-with GNU Automake 1.13. Until we upgrade our tests, we force
-serial-tests beginning with GNU Automake 1.13.
-
-This commit is a minor adaption of libguestfs's (GPLv2+) commit
-a1c89bf03dd432f0e4c8c26fe01fd9b2a50df97e by Richard W.M. Jones.
-
-Signed-off-by: Christian Aistleitner <christian@quelltextlich.at>
----
- configure.ac | 24 +++++++++++++++++++++---
- 1 file changed, 21 insertions(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 01530e0..88cb4d8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -66,9 +66,27 @@ VERSION=$PACKAGE_VERSION
- AC_CONFIG_AUX_DIR([scripts])
- AC_CONFIG_SRCDIR([sm/gpgsm.c])
- AC_CONFIG_HEADER([config.h])
--# Note: For automake 1.13 add the option
--#          serial-tests
--AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip])
-+
-+dnl Initialize automake.  automake < 1.12 didn't have serial-tests and
-+dnl gives an error if it sees this, but for automake >= 1.13
-+dnl serial-tests is required so we have to include it.  Solution is to
-+dnl test for the version of automake (by running an external command)
-+dnl and provide it if necessary.  Note we have to do this entirely using
-+dnl m4 macros since automake queries this macro by running
-+dnl 'autoconf --trace'.
-+m4_define([serial_tests], [
-+    m4_esyscmd([automake --version | awk 'NR==1 {
-+                       split ($NF, V_ARR, ".");
-+                       V_INT=1000000*V_ARR[1]+1000*V_ARR[2]+V_ARR[3]
-+                       if (V_INT >= 1013000)
-+                         # GNU Automake is version 1.13 or newer
-+                         print "serial-tests";
-+                     }'
-+    ])
-+])
-+
-+dnl As we need expansion of the serial_tests macro, do not [quote] it.
-+AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip] serial_tests)
- AC_CANONICAL_HOST
- AB_INIT
--- 
-1.8.1.5
-
index d1eedd2..791d833 100644 (file)
@@ -7,4 +7,4 @@ DIST libgcrypt-1.6.1.tar.bz2 2470885 SHA256 a1c3efea69f8ffe769f488b300ce190eeeb0
 DIST libgcrypt-1.6.2.tar.bz2 2476101 SHA256 de084492a6b38cdb27b67eaf749ceba76bf7029f63a9c0c3c1b05c88c9885c4c SHA512 86003bb61c1fd37d0e54f9b1f48a9d89adb5f623818f67392f19d0de9b28ccb911a728238f8a8d23b875afb3bf7698bbea4da7b3b3a10e049311b9b45fabe472 WHIRLPOOL e25f1035f57c182d8c5e3b608698b97cfc51472d2d39763d9d29abf0af88c751615f6d6b4ed9840fc8e9c055929cd51909c2dca01bc2ac7b37bbc0d4a09dfd29
 EBUILD libgcrypt-1.6.1-r2.ebuild 2239 SHA256 42f114ed1672b048a024efe1873aadf0c5c2d1614ae43c48d2a805ee1e8cbba8 SHA512 77020357c57ba9fb962cf2342f2bce7a99b915f66ca754615f516ee8e5a8437dc86df7290e558ed9f08af91add884e76b89c529df8bf1c45cd73bb3229c2f2f6 WHIRLPOOL eb73a493e60aa57b4534231ba7782cc714f207e03491fe60d084d9b901cabe4eb7ed57540917b79019a15524f4ab3593e8d20d27bdd17e27fcc26a36d56a386e
 EBUILD libgcrypt-1.6.2.ebuild 2151 SHA256 882e94132d062dddacd3aaa474ef5facc07badc6f90463fc67a6fe9554aa59c8 SHA512 76762c85b85fbd45a6f34eaae05dd30d656e553b0d2aafb989344ff2779f0a088bf94c306a7d0eb8eb0d96b374be9611def25a1c6e75ed1278373b032d56ca00 WHIRLPOOL c4bad76d051628fb8d0d52a6838f5690cea6674e93f7b6da11986a4305870bae3a6a7607ff8dadb582e86fb60c0e95eefdb7e7531735d7ba3eb211c7de020093
-EBUILD libgcrypt-9999.ebuild 790 SHA256 abec7d7601114773c95c6a99db797ffb09ab480a1c221ff660aa4f584a5ec1e8 SHA512 f00aad0822d53f77af459f35fd92bc815398acb4e48aed50fed51f932591f0373ce989c712ad134e659813ea68445443e66111c36db33a30343915298b38c170 WHIRLPOOL 811b6d2669e02ec380c7d9ffb161123d0b664dc66a93be7be45e9ed35ac18a99a10a72bff9052ae434fd64c74071e0ba7f3cf4cae26111c032ddfbc99031a0c0
+EBUILD libgcrypt-9999.ebuild 740 SHA256 7c1c81c2b237cf01c72a712e80ea62ead8c52f644e610d46235c8b0c94fd33dc SHA512 bb249640ea10ae6480b834ed09f1c2f8805584d806b0b19b99ed173e37ff8970265e4bedfc015da5490901803e5ff10882b3faee85211d1621fb9599df15c25c WHIRLPOOL 405fa0eda9e08bd88c3487953f36821f989ed650d8f67d87643a1e94284d3a1f31858a399576731e99af4fbd3789bf7e46c0bd8e54c958a6afa416746b9803eb
diff --git a/dev-libs/libgcrypt/files/0002-Fix-building-with-GNU-Automake-1.13.patch b/dev-libs/libgcrypt/files/0002-Fix-building-with-GNU-Automake-1.13.patch
deleted file mode 100644 (file)
index f1bc701..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-From e8e37f6be871d84069658d0c48979d7a12395171 Mon Sep 17 00:00:00 2001
-From: Christian Aistleitner <christian@quelltextlich.at>
-Date: Sun, 14 Jul 2013 12:50:07 +0200
-Subject: [PATCH] Fix building with GNU Automake 1.13+
-
-* configure.ac: Force serial tests for GNU Automake 1.13+.
-(serial_tests): New.
---
-
-GNU Automake switched the default test harness to parallel beginning
-with GNU Automake 1.13. Until we upgrade our tests, we force
-serial-tests beginning with GNU Automake 1.13.
-
-This commit is a minor adaption of libguestfs's (GPLv2+) commit
-a1c89bf03dd432f0e4c8c26fe01fd9b2a50df97e by Richard W.M. Jones.
-
-Signed-off-by: Christian Aistleitner <christian@quelltextlich.at>
----
- configure.ac | 22 +++++++++++++++++++++-
- 1 file changed, 21 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 13541bb..59f8281 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -73,7 +73,27 @@ PACKAGE=$PACKAGE_NAME
- VERSION=$PACKAGE_VERSION
- AC_CONFIG_SRCDIR([src/libgcrypt.vers])
--AM_INIT_AUTOMAKE
-+
-+dnl Initialize automake.  automake < 1.12 didn't have serial-tests and
-+dnl gives an error if it sees this, but for automake >= 1.13
-+dnl serial-tests is required so we have to include it.  Solution is to
-+dnl test for the version of automake (by running an external command)
-+dnl and provide it if necessary.  Note we have to do this entirely using
-+dnl m4 macros since automake queries this macro by running
-+dnl 'autoconf --trace'.
-+m4_define([serial_tests], [
-+    m4_esyscmd([automake --version | awk 'NR==1 {
-+                       split ($NF, V_ARR, ".");
-+                       V_INT=1000000*V_ARR[1]+1000*V_ARR[2]+V_ARR[3]
-+                       if (V_INT >= 1013000)
-+                         # GNU Automake is version 1.13 or newer
-+                         print "serial-tests";
-+                     }'
-+    ])
-+])
-+
-+dnl As we need expansion of the serial_tests macro, do not [quote] it.
-+AM_INIT_AUTOMAKE(serial_tests)
- AC_CONFIG_HEADER(config.h)
- AC_CONFIG_MACRO_DIR([m4])
- AC_CONFIG_LIBOBJ_DIR([compat])
--- 
-1.8.1.5
-
index 5d9f06e..5d777f5 100644 (file)
@@ -7,9 +7,11 @@ EAPI=5
 inherit autotools flag-o-matic user git-2
 
 DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
-EGIT_REPO_URI="git://git.gnupg.org/${PN}.git"
 HOMEPAGE="http://gnupg.org/"
 
+WANT_AUTOMAKE=1.14
+EGIT_REPO_URI="git://git.gnupg.org/${PN}.git"
+
 LICENSE="GPL-2"
 SLOT="0/20"
 KEYWORDS=""
@@ -28,7 +30,6 @@ DEPEND="
 RDEPEND="${CDEPEND}"
 
 src_prepare() {
-       epatch "${FILESDIR}/0002-Fix-building-with-GNU-Automake-1.13.patch";
        ./autogen.sh || die "Autogen failed"
 }